Discord Bot down
Incident Report for myCenter
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 12:45 CDT
Investigating
We are currently investigating this issue.
Posted Jun 22, 2020 - 12:19 CDT
This incident affected: Discord (Main Bot, Customer Service Bot).