Forums Logging In
Incident Report for myCenter
Resolved
The OAuth has been fixed and you should now be able to log in the forums.
Posted Jun 23, 2020 - 05:48 CDT
Investigating
We are currently investigating the issue that means you are unable to login to our Forums site.
The OAuth will be fixed soon.
Posted Jun 23, 2020 - 05:22 CDT
This incident affected: Other (Forums).